Задать вопрос
16 апреля, 15:04

составить программу которая запрашивает n целых чисел и вычисляет их среднее арифметическое

+5
Ответы (1)
  1. 16 апреля, 17:56
    0
    var n, sum, i, j:integer;

    begin

    sum:=0;

    write ('Enter N: ') ;

    readln (n) ;

    writeln ('Enter N numbers:') ;

    for i:=1 to n do

    begin

    read (j) ;

    sum:=sum+j;

    end;

    writeln ('Average is ', sum/n)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу которая запрашивает n целых чисел и вычисляет их среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2.
Ответы (1)
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)