Задать вопрос
16 апреля, 15:28

Число, получаемое в результате приписывания по двойке в начало и конец записи исходного числа.

В Паскале

+1
Ответы (1)
  1. 16 апреля, 16:13
    0
    Var n, k, m: integer;

    begin

    write ('n = ') ; readln (n) ;

    k:=n; m:=1;

    while k>0 do

    begin

    k:=k div 10;

    m:=m*10;

    end;

    k:=2*m*10+n*10+2;

    writeln (k) ;

    end.

    n = 78954

    2789542
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Число, получаемое в результате приписывания по двойке в начало и конец записи исходного числа. В Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1) Строится двоичная запись числа N.
Ответы (1)
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое удалением удалением из исходного всех цифр а.
Ответы (1)
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое из исходного перестановкой его первой и последней цифр.
Ответы (1)
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
1) Строится двоичная запись числа N. 2) К этой записи дописываются справа ещё два разряда по следующему правилу: а) складываются все цифры двоичной записи, и остаток от деления суммы на 2 дописывается в конец числа (справа).
Ответы (1)