Задать вопрос
12 марта, 17:52

Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое из исходного перестановкой его первой и последней цифр.

+4
Ответы (1)
  1. 12 марта, 19:33
    0
    Var a, bug:integer;

    s, s1, s2:string;

    begin;

    readln (a) ;

    str (a, s) ; / / переводим число в строку

    s1:=s[1]; / / запоминаем 1 символ

    s2:=s[length (s) ]; / / запоминаем крайний символ

    delete (s, 1,1) ; / / удаляем 1 символ

    delete (s, length (s),1) ; / / удаляем крайний символ

    insert (s2, s, 1) ; / / ставим сохранённый крайний символ на первое место

    insert (s1, s, length (s)) ; / / ставим сохранённый первый символ в конец

    val (s, a, bug) ; / / делаем строку числом, не забыв о возможности багов

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое из исходного перестановкой его первой и последней цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое удалением удалением из исходного всех цифр а.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)
Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа 1) сумму и произведение его цифр; 2) число, образованное перестановкой цифр исходного числа.
Ответы (1)