Задать вопрос
7 октября, 16:16

Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200.

Составить программу, которая вычисляет факториал числа 7!

+3
Ответы (1)
  1. 7 октября, 18:48
    0
    Первая программа:

    var summ, k, i:Integer; sa:Real;

    begin

    summ:=0;

    k:=0;

    for i:=1 to 200 do

    begin

    if (i mod 3 = 0) then

    begin

    summ:=summ+i;

    k:=k+1;

    end;

    end;

    sa:=summ/k;

    WriteLn (sa) ;

    end.

    Вторая:

    var i, f:Integer;

    begin

    f:=1;

    for i:=1 to 7 do f:=f*i;

    WriteLn (f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
С помощью repeat S = (x / (факториал) 1) + (х^2 / (факториал) 2) + (х^3 / (факториал) 3) + ... + (х^n / (факториал) n) + 0,0001
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
9 класс Циклическое программирование 1. Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до 45 2. Найти сумму нечетных чисел от 79 до 205 3. Найти значение функции на отрезке [1; 10] с шагом 0,5
Ответы (1)
Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000.
Ответы (1)