Задать вопрос
28 ноября, 05:38

9 класс

Циклическое программирование

1. Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до 45

2. Найти сумму нечетных чисел от 79 до 205

3. Найти значение функции на отрезке [1; 10] с шагом 0,5

+1
Ответы (1)
  1. 28 ноября, 08:14
    0
    Первая программа:

    Var S, A:integer;

    Begin

    S:=0;

    For A: = 5 to 45 do

    if A mod 4 = 0 then S:=S+A;

    WriteLn ('S = ', S) ;

    End.

    Результат работы программы:

    S = 260

    Вторая программа:

    Var A, S:integer;

    Begin

    S:=0;

    For A: = 79 to 205 do

    if A mod 2 0 then S:=S+A;

    WriteLn ('S = ', S) ;

    End.

    Результат работы программы:

    S = 9088

    Третья программа:

    Var

    x:byte;

    Begin

    WriteLn ('f (x) = x^2') ;

    For x: = 1 to 20 do

    WriteLn ('f (', x/2:3,') = ', Sqr (x/2))

    End.

    Результат работы программы:

    f (x) = x^2

    f (0.5) = 0.25

    f (1) = 1

    f (1.5) = 2.25

    f (2) = 4

    f (2.5) = 6.25

    f (3) = 9

    f (3.5) = 12.25

    f (4) = 16

    f (4.5) = 20.25

    f (5) = 25

    f (5.5) = 30.25

    f (6) = 36

    f (6.5) = 42.25

    f (7) = 49

    f (7.5) = 56.25

    f (8) = 64

    f (8.5) = 72.25

    f (9) = 81

    f (9.5) = 90.25

    f (10) = 100
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «9 класс Циклическое программирование 1. Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до 45 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)