Задать вопрос
3 января, 15:29

Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда.

+4
Ответы (1)
  1. 3 января, 16:02
    0
    Программа получает на вход N, почле чего в цикле постепенно обрабатывает все натуральные числа от 1 до N включительно и в ячейку памяти s откладывает их квадраты.

    program summa;

    uses crt;

    var N, a, s, i: integer;

    begin

    read (N) ; a:=0; s:=0;

    for i:=1 to N do

    begin

    a:=a+1;

    s:=s + (a*a) ;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления суммы квадратов первых N членов натурального ряда, каждое из которых при делении на M дает в остатке F. (Паскаль)
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Помогите решить задачи по информатике! Нужно написать программы в Python 1. Составьте программу вычисления первых десяти членов последовательности, заданной формулами n-го члена: xn = n²-10. 2.
Ответы (2)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)