Задать вопрос
20 декабря, 19:51

Составить программу вычисления суммы квадратов первых N членов натурального ряда, каждое из которых при делении на M дает в остатке F. (Паскаль)

+4
Ответы (1)
  1. 20 декабря, 20:31
    0
    Var x, n, m, f, s: integer;

    begin

    write ('Введите N: ') ; readln (n) ;

    write ('Введите M: ') ; readln (m) ;

    write ('Введите F: ') ; readln (f) ;

    for x : = 1 to n do

    if (x mod m = f) then s : = s + sqr (x) ;

    writeln ('Сумма: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления суммы квадратов первых N членов натурального ряда, каждое из которых при делении на M дает в остатке F. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Необходимо составить программу в Паскале которая: Вычислить сумму квадратов первых 15 натуральных чисел, каждое из которых при делении на 5 дает в остатке 3.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)