Задать вопрос
16 июля, 09:19

Ученики школы № 100 любят загадывать загадки. Один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение. Напишите программу, угадывающую задуманные числа.

+1
Ответы (1)
  1. 16 июля, 12:42
    0
    Var s, p, a, b: integer;

    begin

    readln (s, p) ;

    a:=round ((s+sqrt (s*s-4*p)) / 2) ;

    b:=s-a;

    writeln (a,' ', b) ;

    end.

    Пример:

    73 1200

    48 25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ученики школы № 100 любят загадывать загадки. Один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Из 40 учащихся нашего класса 32 любят молоко, 21 - лимонад, а 15 - и молоко, и лимонад. Сколько ребят в нашем классе не любят ни молоко, ни лимонад? 2.
Ответы (1)
Самыми любимыми мультами шестиклассников являются Простоквашино Ну Погоди и Том и Джерри. 25 человек любят Ну Погоди, из которых 3 любят еще и Простоквашино, а 4 Том и Джерри. Простоквашино любят 15 человек, 6 из которых любят по 2 мульта.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
В классе 18 учащихся. Половина из них любят только математику, трое любят литературу и историю, остальные любят физкультуру и музыку. Сколько детей любят физкультуру и музыку?
Ответы (2)
6. В классе 18 учащихся. Половина из них любят только математику, трое любят литературу и историю, остальные любят физкультуру и музыку. Сколько детей любят физкультуру и музыку? 7. Переведите: а) 448 бит в байты б) 147456 бит в кбайты
Ответы (1)