Задать вопрос
24 апреля, 13:25

Составьте програму, которая вводит с клавиатуры длину и ширину прямаугольника и определяет, является ли прямаугольник квадратом. Постройте данный прямоугольник (единицу длины показать 5 пикселями)

+1
Ответы (1)
  1. 24 апреля, 15:44
    0
    uses crt, graphABC;

    var x, y, xc, yc:integer;

    begin

    xc:=windowwidth div 2;

    yc:=windowheight div 2;

    write ('Введите ширину ') ;

    read (x) ;

    write ('Введите длину ') ;

    read (y) ;

    if (x=y) then write ('Это квадрат') ;

    hidecursor;

    setpencolor (clAqua) ;

    rectangle (xc-x*5, yc-y*5, xc+x*5, yc+y*5) ;

    floodfill (xc, yc, clAqua) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте програму, которая вводит с клавиатуры длину и ширину прямаугольника и определяет, является ли прямаугольник квадратом. Постройте ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то вывести - 1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.
Ответы (1)
Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ... 1) Разработайте программу, которая вводит число К и проверяет, является ли оно простым.
Ответы (1)
Составте програму, которая вводит число с клавиатуры, и если оно отрицательное возводит его в квадрат
Ответы (1)
составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата.
Ответы (1)
Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу
Ответы (1)