Задать вопрос
12 сентября, 00:41

составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок

+3
Ответы (1)
  1. 12 сентября, 02:46
    0
    Pascal:

    program strings;

    uses crt;

    var i, open, close:integer;

    a:String;

    begin

    open:=0;

    end:=0;

    clrscr;

    write ('Введите строку: ') ; readln (a) ;

    for i:=1 to length (a) do

    begin

    if a[i]=' (' then open:=open+1;

    if a[i]=') ' then close:=close+1;

    end;

    writeln ('Открывающихся скобок: ', open, ' штук') ;

    writeln ('Закрывающихся скобок: ', close, ' штук') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале. P. S формулы в программе быть не должно
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Написать исходный код в Pascal-е. Решить задачу по обработке строковых данных с использованием подпрограмм: В строке, среди знаков могут встречаться открывающие и закрывающие скобки.
Ответы (2)