Задать вопрос
28 августа, 05:17

Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале.

P. S формулы в программе быть не должно

+4
Ответы (1)
  1. 28 августа, 08:24
    0
    var a:string;

    i:integer;

    c:boolean;

    begin

    readln (a) ;

    repeat

    if pos ('+', a) 0 then begin inc (i) ; delete (a, pos ('+', a),1) ; end;

    if pos ('-', a) 0 then begin inc (i) ; delete (a, pos ('-', a),1) ; end;

    if (pos ('+', a) = 0) and (pos ('-', a) = 0) then c:=true;

    until c;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале. P. S формулы в программе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составьте программу, которая: в) заменяет в формуле, заданной с клавиатуры, круглые скобки на квадратные.
Ответы (1)