Задать вопрос
11 сентября, 23:33

составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит на экран в строку данный массив. Найти сумму неположительных элементов массива, количество элементов кратных 3, произведение элементов, стоящих на четных местах

+5
Ответы (1)
  1. 12 сентября, 03:20
    0
    program z1;

    uses crt;

    var m: array[1 ... 10] of integer;

    i, a, b, c:integer;

    begin

    for i:=1 to 10 do

    readln (m[i]) ;

    writeln;

    a:=0;

    b:=0;

    c:=1;

    for i:=1 to 10 do

    begin

    if m[i]<=0 then a:=a+m[i];

    if m[i] mod 3 = 0 then b:=b+1;

    if i mod 2 = 0 then c:=c*m[i];

    end;

    writeln (Сумма отриц'', a) ;

    writeln (кратные 3'', b) ;

    writeln (произв'', c)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая запрашивает значения элементов одномерного числового массива А, состоящего из10 элементов, формирует и выводит на экран в строку данный массив.
Ответы (1)
Составьте программу, которая запрашивает значение элементов одномерного массива A, состоящего из 10 элементов, формирует и выводит на экран в строку данный массив.
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)