Задать вопрос
10 декабря, 02:38

Составьте программу, которая запрашивает значения элементов одномерного числового массива А, состоящего из10 элементов, формирует и выводит на экран в строку данный массив.

Найти сумму элементов, кратных 3;

количество нулевых элементов;

и произведение элементов, стоящих на нечётных местах.

+1
Ответы (1)
  1. 10 декабря, 03:32
    0
    var

    z, i, g, s:longint

    a:array[0 ... 100]of longint;

    begin

    z:=1;

    for i:=1 to 10 do

    begin

    read (a[i]) ;

    if a[i] mod 3=0 then inc (s, a[i]) ;

    if a[i]=0 then inc (g) ;

    if i mod 2>0 then z:=z*a[i];

    write (a[i],' ') ;

    end;

    writeln;

    writeln (s) ;

    writeln (g) ;

    writeln (z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая запрашивает значения элементов одномерного числового массива А, состоящего из10 элементов, формирует и выводит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит на экран в строку данный массив.
Ответы (1)
Составьте программу, которая запрашивает значение элементов одномерного массива A, состоящего из 10 элементов, формирует и выводит на экран в строку данный массив.
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)