Задать вопрос
31 октября, 07:29

Создать программу, которая находит максимальное отрицательное число, кратное 2.

+2
Ответы (1)
  1. 31 октября, 10:48
    0
    Program n1;

    const n=10;

    var a: array[1 ... n] of integer;

    i, max: integer;

    begin

    randomize;

    a[1]:=random (11) - 10;

    max:=a[1];

    writeln ('исходный массив:') ;

    for i:=2 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    if (abs (a[i])
    then max:=a[i];

    end;

    writeln;

    writeln ('максимальный отрицательный, кратный 2: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу, которая находит максимальное отрицательное число, кратное 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)
Напишите программу, которая в последовательности N натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход N-ное количество чисел. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)
На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.
Ответы (1)