Задать вопрос
27 мая, 15:28

Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Ко личе ство чисел не пре вы ша ет 1000. Введённые числа не пре вы ша ют 30 000. Пграмма должна вывести одно число - максимальное число, кратное 5.

+5
Ответы (1)
  1. 27 мая, 17:37
    0
    Program kratnoe;

    var N, i, a, max: integer;

    begin

    writeln ('Введите количество чисел:') ; Readln (N) ;

    max:=0;

    For i:=1 to N do

    begin

    write ('Введите число:') ; readln (a) ;

    if a mod 5 = 0 then

    if a>max then max:=a;

    end;

    writeln ('ответ:', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)