Задать вопрос
31 октября, 06:20

Напишите программу для решения задачи

Определить является ли данное число n чётным двухзначным числом

+2
Ответы (2)
  1. 31 октября, 09:40
    0
    Var

    n: integer;

    begin

    readln (n) ;

    writeln ((n mod 2 = 0) and (n div 10 > 0) and (n div 100 = 0)) ;

    end.
  2. 31 октября, 10:17
    0
    Var

    n,

    check_n,

    : integer;

    flag : boolean;

    Begin

    write ('Введите чило') ;

    readln (n) ;

    {Проверяется, является ли n четным}

    if n mod 2 = 0

    then

    flag = true;

    else

    flag = false;

    {Проверяется, является ли n двухзначным}

    if n div 10 0

    then

    flag = true;

    else

    flag = false;

    if flag

    then

    writeln ('Число ', n, ' является четным двухзначным') ;

    else

    writeln ('Число ', n, ' не является четным двухзначным') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для решения задачи Определить является ли данное число n чётным двухзначным числом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы