Задать вопрос
29 ноября, 11:55

Напишите программу, которая в последовательности

N натуральных чисел определяет максимальное

число, кратное 4. Программа получает на вход N-ное количество чисел.

В последовательности всегда имеется число, кратное 4. Программа

должна вывести одно число - максимальное число, кратное 4.

+3
Ответы (1)
  1. 29 ноября, 12:01
    0
    var

    i, n, k, max: integer;

    begin

    readln (n) ;

    max : = Integer. MinValue;

    for i : = 1 to n do

    begin

    readln (k) ;

    if (k mod 4 = 0) then

    max : = System. Math. Max (max, k) ;

    end;

    writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности N натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)