Задать вопрос
25 июня, 20:08

Дан массив из N элементов. Найти сумму элементов с четными номерами и отдельно - с нечетными номерами. В программе Pascal

+2
Ответы (1)
  1. 25 июня, 23:25
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, s1, s2:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) ;

    write (a[i]:4) ;

    end;

    writeln;

    s1:=0; s2:=0;

    for i:=1 to n do

    if i mod 2 = 1 then s1:=s1+a[i] else s2:=s2+a[i];

    writeln ('s1 = ', s1,' s2 = ', s2) ;

    end.

    Пример:

    Массив A:

    21 46 43 5 40 32 26 34 29 48

    s1 = 159 s2 = 165
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N элементов. Найти сумму элементов с четными номерами и отдельно - с нечетными номерами. В программе Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)