Задать вопрос
10 января, 15:03

Помогите написать программу в Паскаль.

Сформировать массив, подметить кол-во отрицательных элементов и заменить их на 2

+4
Ответы (1)
  1. 10 января, 17:58
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    Begin

    Randomize;

    k:=0;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (' ', A[i]) ;

    if A[i] < 0 then

    Begin

    k:=k+1;

    A[i]:=2

    End;

    End;

    WriteLn;

    WriteLn ('Количество отрицательных элементов: ', k) ;

    Write ('Новый массив:') ;

    For i: = 1 to N do

    Write (' ', A[i])

    End.

    Пример работы программы:

    Исходный массив: - 1 - 9 7 - 2 - 5 - 3 - 1 6 3 - 6 9 8 - 10

    Количество отрицательных элементов: 8

    Новый массив: 2 2 7 2 2 2 2 6 3 2 9 8 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскаль. Сформировать массив, подметить кол-во отрицательных элементов и заменить их на 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Составить программу (Паскаль) Сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от - 10 до + 10. Вывести кол-во нулевых элементов, сумму элементов кратных 3 и среднее арифметическое всех элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан одномерный массив. Из элементов массива равных 100, сформировать массив b., а из элементов меньших 33, сформировать массив с.
Ответы (1)