Задать вопрос
10 января, 14:45

Написать в паскале программу, которая считает значение выражения x-1/x+x-2/2x ... + x-n/nx при заданных x и n

+2
Ответы (1)
  1. 10 января, 16:49
    0
    Var x, s, a:real; n, i:integer;

    begin

    write ('x=') ; readln (x) ;

    write ('n=') ; readln (n) ;

    s:=0;

    for i:=1 to n do

    begin

    a: = - (x-i) / (i*x) ;

    s:=s+a;

    end;

    writeln ('s=', s:5:2) ;

    end.

    Пример:

    x=1.5

    n=10

    s = 3.74
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать в паскале программу, которая считает значение выражения x-1/x+x-2/2x ... + x-n/nx при заданных x и n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Написать программу на Паскаль: 1) Составить программу, которая при заданных значениях x и y вычисляет функции A с точностью 10^-3 A = ((x*y) / (x+y)) / (1+√ (x²-x-4)) ;
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)