Задать вопрос
26 сентября, 16:35

Написать программу на Паскаль:

1) Составить программу, которая при заданных значениях x и y вычисляет функции A с точностью 10^-3

A = ((x*y) / (x+y)) / (1+√ (x²-x-4)) ;

2) Составить программу, которая запрашивает ввод коэффициентов a, b, c, d уравнение вида "ax+b=c+dx", а после ввода коффициентов напечатает или решение или сообщение о том, что решение не существует, коэффициенты уравнения вводятся в соответствии одному из этих случаев.

+2
Ответы (1)
  1. 26 сентября, 20:04
    0
    1) Точность вычисления в программе не задается. Указано только количество цифр дробной части (3), которое требуется вывести на экран.

    var x, y, a:real;

    begin

    write ('x = ') ;

    readln (x) ;

    write ('y = ') ;

    readln (y) ;

    if x*x-x-4>=0 then

    begin

    a: = ((x*y) / (x+y)) / (1+sqrt (x*x-x-4)) ;

    writeln ('a = ', a:5:3) ;

    end

    else writeln ('Корень из отрицательного числа') ;

    end.

    2)

    var a, b, c, d:real;

    begin

    writeln ('Введите a, b, c, d:') ;

    readln (a, b, c, d) ;

    if (a=d)

    then if (c=b) then writeln ('Бесконечно много решений')

    else writeln ('Решения нет')

    else writeln ('x = ', (c-b) / (a-d)) ;

    end.

    Пример:

    Введите a, b, c, d:

    2 1 4 3

    x = - 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскаль: 1) Составить программу, которая при заданных значениях x и y вычисляет функции A с точностью 10^-3 A = ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
Как это решать? И что тут вообще надо сделать? A+B Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны 2 числа a и b. Найти сумму этих чисел.
Ответы (1)
Вводятся три целых числа. Выведите YES, если они расположены в порядке неубывания (каждое следующее больше либо равно предыдущего), NO иначе. Пример 1 Ввод Вывод 1 2 3 YES Пример 2 Ввод Вывод 1 3 2 NO Пример 3 Ввод Выво д 1 3 3 YES
Ответы (1)