Задать вопрос
1 июня, 17:31

Составить программу (Паскаль) Сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от - 10 до + 10. Вывести кол-во нулевых элементов, сумму элементов кратных 3 и среднее арифметическое всех элементов массива.

+2
Ответы (1)
  1. 1 июня, 18:09
    0
    var t:array[0 ... 19] of byte;

    i, k, l, s:integer;

    begin

    k:=0;

    l:=0;

    s:=0;

    for i:=0 to 19 do begin

    t[i]:=random (21) - 10;

    write (t[i],' ') ;

    if t[i]=0 then k:=k+1;

    if t[i] mod 3=0 then s:=s+t[i];

    l:=l+t[i];

    end;

    write ('колво 0 ', k) ;

    write ('сумма кратных 3 ', s) ;

    write ('средне арефм ', l/20) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу (Паскаль) Сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от - 10 до + 10. Вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)