Задать вопрос
29 февраля, 23:29

Pascal. В одномерном массиве элементы меньше 1 умножить на 2, а остальные увеличить на 3

+3
Ответы (1)
  1. 1 марта, 03:10
    0
    Var

    x:array [1 ... 10] of integer;

    i:integer;

    begin

    writeln ('Введите массив') ;

    for i:=1 to 10 do begin

    read (x[i]) ;

    if x[i]<1 then

    x[i]:=x[i]*2

    else

    x[i]:=x[i]+3;

    end;

    for i:=1 to 10 do

    write (x[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. В одномерном массиве элементы меньше 1 умножить на 2, а остальные увеличить на 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)