Задать вопрос
14 декабря, 23:43

1. Дана последовательность целых чисел, вводимых с клавиатуры (до 0). Найти среднее арифметическое чисел.

+2
Ответы (1)
  1. 15 декабря, 00:33
    0
    Var

    A, N:integer;

    S:real;

    Begin

    N:=-1;

    S:=0;

    Repeat

    Read (A) ;

    N:=N+1;

    S:=S+A;

    Until A = 0;

    WriteLn ('Среднее арифметическое введённых чисел равно: ', S/N) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дана последовательность целых чисел, вводимых с клавиатуры (до 0). Найти среднее арифметическое чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
С клавиатуры вводится целое число N. Затем вводится N целых чисел. Перед вводом каждого из чисел должно появляться сообщение вида "Введите i-е число", где i - номер очередного числа. Найдите среднее арифметическое вводимых чисел.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)