Задать вопрос
31 марта, 04:32

С клавиатуры вводится целое число N. Затем вводится N целых чисел. Перед вводом каждого из чисел должно появляться сообщение вида "Введите i-е число", где i - номер очередного числа. Найдите среднее арифметическое вводимых чисел.

+2
Ответы (1)
  1. 31 марта, 07:33
    0
    var

    sum, n, i, tmp : integer;

    begin

    readln (n) ;

    sum : = 0;

    for i : = 1 to n do

    begin

    write ('Введите ', i, '-ое число') ;

    readln (tmp) ;

    sum : = sum + tmp;

    end;

    writeln (sum / n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится целое число N. Затем вводится N целых чисел. Перед вводом каждого из чисел должно появляться сообщение вида "Введите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)