Задать вопрос
16 июля, 10:10

Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале

+1
Ответы (1)
  1. 16 июля, 13:55
    0
    Uses crt;

    Var A:array[1 ... 10]of integer;

    q, w, i, k, j:integer;

    begin

    randomize;

    for q: = 1 to 10 do

    begin

    A[q] : = random (256) ;

    write (A[q]:4)

    end;

    for i : = 1 to 9 do

    for j : = 1 to 10 - i do

    if A[j] > A[j + 1] then begin

    k : = A[j];

    A[j] : = A[j + 1];

    A[j + 1] : = k;

    end;

    for i:=1 to 10 do

    w: = (A[1]+A[10]) / 2;

    write (w)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Написать программу на Паскале: Среди 10 целых положительных и отрицательных чисел: 1. Найти максимальное и минимальное значения. 2. Среднее арифметическое среди трехзначных, оканчивающихся на 1 и кратных 7.
Ответы (2)
1. Найти среднее арифметическое двузначных чисел кратных 7 2. Найти среднее арифметическое первых 10 чисел делящихся на 5 (в паскале)
Ответы (1)
Задачи по информатике, нужно в Паскале сделать программы: 2. Дано натуральное n. Вычислить n!; среднее арифметическое чисел от 1 до n; и среднее геометрическое от 1 до n. 3. Вводится натуральное число a.
Ответы (1)
Создать программы в Паскале: 1. Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел. 2. Вычислить расстояние между двумя точками с заданными координатами (х1, у2) и (х2, у2)
Ответы (1)