Задать вопрос
26 марта, 18:33

1. Найти среднее арифметическое двузначных чисел кратных 7

2. Найти среднее арифметическое первых 10 чисел делящихся на 5

(в паскале)

+1
Ответы (1)
  1. 26 марта, 18:42
    0
    Begin

    var m, u, p, t:integer;

    for var i:=10 to 99 do

    if i mod 7 = 0 then

    begin

    m:=m+i; u:=u+1;

    end;

    Writeln ('Среднее чисел которые дклятся на 7=', m/u) ;

    for var i:=1 to 99 do

    if i mod 5 = 0 then

    begin

    p:=p+i; t:=t+1;

    if t > 10 then break;

    end;

    Writeln ('Среднее чисел которые дклятся на 5=', p/t) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Найти среднее арифметическое двузначных чисел кратных 7 2. Найти среднее арифметическое первых 10 чисел делящихся на 5 (в паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)