Задать вопрос
22 октября, 04:07

Задачи:

1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.

2) Найти среднее арифмитическое нечетных чисел кратных 5 в интервале от 1 до 70

3) Найти разность между суммой двузначных нечетных чисел и суммой двузначных четных чисел.

(задачи на бэйсике)

+2
Ответы (1)
  1. 22 октября, 06:12
    0
    1. var a, b, i:integer;

    begin

    for i:=10 to 99 do begin

    if i mod 3=0 then inc (a) ;

    if i mod 5 = 0 then inc (b) ;

    end;

    Writeln ('числа, кратные 3: ', a,' числа, кратные 5: ', b) ;

    if a>b then writeln ('чисел кратных 3 больше') else

    writeln ('чисел кратных 5 больше') ;

    end.

    2. var k, i:integer; s:real;

    begin

    for i:=1 to 70 do

    if (i mod 20) and (i mod 5 = 0) then begin

    k:=k+1;

    s:=s+i;

    end;

    s:=s/k;

    writeln ('среднее арифметическое чисел, кратных 5 = ', s:10:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5. 2) Найти среднее арифмитическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Последовательно вводятся целые положительные числа, пока не будет введено отрицательное число. Определить разность между суммой чисел кратных семи и количеством четных чисел.
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Заполнить массив случайными числами в интервале[ - 100; 100] и поменять местами соединение элементы, стоящие на четных местах, с элементами, стоящими на нечетных местах. Вычислить кол-во четных элементов. Гномья сортировка.
Ответы (1)