Задать вопрос
22 октября, 03:32

Дан массив из N элементов. Составить программу, сортирующую по возрастанию все числа с нечётными индексами в массиве.

+5
Ответы (1)
  1. 22 октября, 04:46
    0
    var

    a: array [1 ... 100] of integer;

    i, j, n, k: integer;

    begin

    readln (n) ;

    for i: = 1 to n do readln (a[i]) ;

    for i: = 1 to n do if Odd (i) then

    for j: = 1 to n-i do if Odd (j) then

    if a[j]>a[j+2] then begin

    k: = a[j];

    a[j]: = a[j+2];

    a[j+2]: = k

    end;

    for i: = 1 to n do write (a[i],' ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N элементов. Составить программу, сортирующую по возрастанию все числа с нечётными индексами в массиве. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)