Задать вопрос
10 ноября, 08:46

Дано два числа. Если числа положительны, то уменьшите их на 2.

Если числа отрицательны, то увеличить их на 2. Если первое положительное, а второе отрицательно, то найти их произведение. Если первое отрицательно, а второе положительно, то найдите их разность

+4
Ответы (1)
  1. 10 ноября, 11:30
    0
    Program pr;

    uses crt;

    var a, b:real;

    Begin

    writeln ('Введите первое число') ;

    readln (a) ;

    writeln ('Введите второе число') ;

    readln (b) ;

    if (a<0) and (b<0)

    then

    Begin

    a:=a+2;

    b:=b+2;

    writeln ('a = ', a) ;

    writeln ('b = ', b) ;

    end

    else

    if (a>0) and (b<0)

    then

    writeln ('a*b = ', a*b)

    else

    if (a0)

    then

    writeln ('b-a = ', b-a)

    else writeln ('Ни одно условие не выполняется') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано два числа. Если числа положительны, то уменьшите их на 2. Если числа отрицательны, то увеличить их на 2. Если первое положительное, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Напишите программу в Паскале по условию Даны действительные числа x, y. Если х, у отрицательны, то каждое значение заменить его модулем; если отрицательное только одно из них, то оба значения увеличить на 27;
Ответы (1)
Ввести 2 числа если первое кратно 4 а второе положительное, то уменьшить их произведение в 3 раза, в противном случае увеличить их произведение в 4 раза
Ответы (1)