Задать вопрос
29 мая, 05:41

Помогите решить задачу по информатике (записать на языке Паскаля) с объяснениями поэтапно

Создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20]

Вычислить кол-во элементов массива, значения которых превышают среднее арифметическое значений его элементов. Написать алгоритм

+4
Ответы (1)
  1. 29 мая, 09:20
    0
    Program n1;

    const n=10;

    var a: array[1 ... n] of integer;

    i, k, sum: integer;

    begin

    randomize;

    sum:=0;

    k:=0;

    for i:=1 to n do

    begin

    a[i]:=random (21) ;

    sum:=sum+a[i];

    end;

    for i:=1 to n do if a[i] > sum/n then k:=k+1;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу по информатике (записать на языке Паскаля) с объяснениями поэтапно Создать массив а из десяти целых чисел, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов
Ответы (1)
1. Создать массив из 20-ти случайных чисел (значения от 0 до 100). Вывести на экран значения массива строкой. Вычислить сумму элементов массива! 2. Создать массив из 20-ти случайных чисел (значения от 0 до 100).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)