Задать вопрос
29 мая, 04:11

дано 3 числа. Если модуль хотя бы одного из них больше 1, то найти их среднее арифметическое, иначе - их произведение

+4
Ответы (1)
  1. 29 мая, 06:16
    0
    Program gt;

    var a, b, c, s:real;

    begin

    read (a, b, c) ;

    if (abs (a) >1) or (abs (b) >1) or (abs (c) >1) then s: = (a+b+c) / 3 else s:=a*b*c;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано 3 числа. Если модуль хотя бы одного из них больше 1, то найти их среднее арифметическое, иначе - их произведение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Надо решить четыре задачи. 1) Дано два числа, если их сумма больше пяти, то найти корень квадратного из этой суммы, в противоположенном случаи найти квадрат суммы.
Ответы (1)
Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Написать на языке Packal
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Информатика 9 класс 2) Даны 4 числа, если сумма первых двух больше или равна сумме вторых двух, то найти сумму и произведение этих чисел, иначе найти среднее арифметическое и увеличить каждое число на 3.
Ответы (1)
Что получится в результате работы следующего алгоритма, если 1) a=2, b=5, 2) a=0, b=-2 алг пример цел a, b, c нач ввод a, b если a>0 то если b>0 то c:=a+b иначе c:=10 кв иначе если b>0 то c:=a*b иначе c:=0 кв кв вывод c кон
Ответы (2)