Задать вопрос
13 апреля, 10:26

В двумерном целочисленном массиве положительные элементы заменить их квадратами

+1
Ответы (1)
  1. 13 апреля, 10:38
    0
    Const

    N = 3;

    Var

    A:Array[1 ... N, 1 ... N] of integer;

    i, j:integer;

    Begin

    Randomize;

    WriteLn ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    For j: = 1 to N do

    Begin

    A[i, j]:=random (21) - 10;

    Write (A[i, j]:3,' ')

    End;

    WriteLn

    End;

    WriteLn;

    WriteLn ('Переработанный массив:') ;

    For i: = 1 to N do

    Begin

    For j: = 1 to N do

    Begin

    if A[i, j]>0 then A[i, j]:=A[i, j]*A[i, j];

    Write (A[i, j]:3,' ') ;

    End;

    WriteLn

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном целочисленном массиве положительные элементы заменить их квадратами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Определить, имеется ли в двумерном целочисленном массиве, заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равное B?
Ответы (1)
Определить имеется ли в двумерном целочисленном массиве заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равного В (В свое видимо задавать)
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.
Ответы (1)