Задать вопрос
29 апреля, 10:15

Определить имеется ли в двумерном целочисленном массиве заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равного В (В свое видимо задавать)

+2
Ответы (1)
  1. 29 апреля, 14:13
    0
    Const

    n=10; m=7;

    var

    a:array[1 ... n, 1 ... m]of integer;

    flag, i, j, b:integer;

    begin

    for i:=1 to n do

    begin

    writeln;

    for j:=1 to m do

    begin

    a[i, j]:=random (312) - 111;

    write (a[i, j]:4) ;

    end;

    end;

    writeln;

    Writeln ('B?') ;

    readln (b) ;

    for i:=1 to n do

    for j:=1 to m do

    if a[i, j]=b then

    flag:=1;

    if flag=1 then

    writeln ('Yes')

    else

    writeln ('N') ;

    end.

    вариант 2

    const

    n=10; m=7;

    var

    a:array[1 ... n, 1 ... m]of integer;

    k, i, j, b:integer;

    begin

    for i:=1 to n do

    begin

    writeln;

    for j:=1 to m do

    begin

    a[i, j]:=random (312) - 111;

    write (a[i, j]:4) ;

    end;

    end;

    writeln;

    Writeln ('B?') ;

    readln (b) ;

    for i:=1 to n do

    for j:=1 to m do

    if a[i, j]=b then

    k:=k+1;

    if k0 then

    writeln ('Yes')

    else

    writeln ('N') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить имеется ли в двумерном целочисленном массиве заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить, имеется ли в двумерном целочисленном массиве, заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равное B?
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
В целочисленном массиве A 20 случайных чисел из интервала от - 10 до 15. Подсчитать количество отрицательных чисел в этом массиве
Ответы (1)