Задать вопрос
8 февраля, 05:56

Определить, имеется ли в двумерном целочисленном массиве, заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равное B?

+2
Ответы (1)
  1. 8 февраля, 09:12
    0
    Var a:array [1 ... 30,1 ... 30] of integer;

    i, j, n, m, b:integer;

    find:boolean;

    begin

    randomize;

    writeln ('введите размерность матрицы ') ;

    readln (n, m) ;

    writeln ('введите число b ') ;

    readln (b) ; find:=false;

    for i:=1 to N do

    for j:=1 to M do

    begin

    a[i, j]:=-110+random (200) ;

    if a[i, j]=b then

    begin

    writeln ('Элемент в массиве ', a[i, j]:5, ' = ', b:5) ; find:=true;

    exit; {остальные эл-ты не рассм.}

    end

    end;

    if find=false then writeln ('элемент не найден') ;

    end.

    {2 Способ}

    var a:array [1 ... 30,1 ... 30] of integer;

    i, j, n, m, b:integer;

    find:boolean;

    begin

    randomize;

    writeln ('введите размерность матрицы ') ;

    readln (n, m) ;

    writeln ('введите число b ') ;

    readln (b) ; find:=false;

    for i:=1 to N do

    begin

    for j:=1 to M do

    begin

    a[i, j]:=-110+random (200) ; write (a[i, j]:7) ;

    end;

    writeln;

    end;

    for i:=1 to N do

    for j:=1 to M do

    if a[i, j]=b then

    begin

    writeln ('Элемент в массиве ', a[i, j]:5, ' = ', b:5) ; find:=true;

    exit; {остальные эл-ты не рассм.}

    end;

    if find=false then writeln ('элемент не найден') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, имеется ли в двумерном целочисленном массиве, заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить имеется ли в двумерном целочисленном массиве заданном с помощью генератора случайных чисел в диапазоне (-111; 200) значение элемента равного В (В свое видимо задавать)
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
1. В массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить: сумму элементов, которые кратны 5. 2. В массиве B (6) случайных целых чисел (диапазон чисел [-4 ... 53]) определить: количество элементов, которые меньше 7.
Ответы (1)