Задать вопрос
1 ноября, 01:43

1. В

массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить:

сумму элементов,

которые кратны 5.

2. В

массиве B (6) случайных целых чисел (диапазон чисел [-4 ... 53]) определить:

количество элементов, которые меньше 7.

+2
Ответы (1)
  1. 1 ноября, 02:21
    0
    1.

    var i, summa: integer;

    A: array [1 ... 11] of integer;

    begin

    summa:=0;

    randomize;

    write ('Массив: ') ;

    for i:=1 to 11 do begin

    A[i]:=random (36) - 10;

    write (A[i],' ') ;

    end;

    writeln;

    for i:=1 to 11 do

    if A[i] mod 5 = 0 then summa:=summa+A[i];

    writeln ('Сумма чисел кратных 5 = ', summa) ;

    end.

    2.

    var i, s: integer;

    A: array [1 ... 6] of integer;

    begin

    s:=0;

    randomize;

    write ('Массив: ') ;

    for i:=1 to 6 do begin

    A[i]:=random (58) - 4;

    write (A[i],' ') ;

    end;

    writeln;

    for i:=1 to 6 do

    if A[i] < 7 then s:=s+1;

    writeln ('Количество элементов меньших 7: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. В массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить: сумму элементов, которые кратны 5. 2. В массиве B (6) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
В массиве В (12) случайных целых чисел (диапазон чисел [ - 5 ... 60]) определить: а) сумму элементов б) количество элементов, которые меньше 7
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Ответьте в кумире или Паскале 1. Найти среднее арифметическое значений всех элементов массива, состоящего их случайных положительных чисел. 2. В массиве из 15-ти целых случайных чисел из диапазона [-30; 70] найти минимальный положительный элемент. 3.
Ответы (1)