Задать вопрос
15 сентября, 03:25

1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов. (Это означает, что нужно сосчитать сумму произведений первого и второго, третьего и четвертого, пятого и шестого элементов, и так далее.)

2) Опишите на русском языке или одном из языков программирования алгоритм поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

+1
Ответы (1)
  1. 15 сентября, 03:45
    0
    Первый алгоритм:

    const

    n=30;

    var

    a:array[1 ... 30] of integer;

    s:longint;

    i:integer;

    begin

    { формируем массив }

    Randomize;

    Writeln ('Элементы массива:') ;

    for i:=1 to n do

    begin a[i]:=Random (51) - 25; Write (a[i]:4) end;

    Writeln;

    { собственно, алгоритм }

    s:=a[1]*a[2]; i:=3;

    while i<=n-1 do

    begin s:=s+a[i]*a[i+1]; i:=i+2 end;

    Writeln ('Сумма пар произведений равна ', s)

    end.

    Тестовое решение:

    Элементы массива:

    1 10 - 9 - 12 - 2 20 21 14 5 19 21 - 14 - 10 - 17 5 - 9 - 8 17 18 11 - 21 - 3 - 15 - 10 - 15 - 16 - 15 2 3 21

    Сумма пар произведений равна 846

    Второй алгоритм

    const

    n=30;

    var

    a:array[1 ... 30] of integer;

    smax, imax:longint;

    i:integer;

    begin

    { формируем массив }

    Randomize;

    Writeln ('Элементы массива:') ;

    for i:=1 to n do

    begin a[i]:=Random (51) - 25; Write (a[i]:4) end;

    Writeln;

    { собственно, алгоритм }

    smax:=a[1]+a[2]; imax:=1;

    for i:=2 to n-1 do

    if smax
    begin smax:=a[i]+a[i+1]; imax:=i end;

    Writeln ('Номер первого из пары элементов с максимальной суммой: ', imax)

    end.

    Тестовое решение:

    Элементы массива:

    23 13 - 11 - 1 - 18 20 - 23 1 - 21 - 10 7 15 - 2 24 - 18 - 22 - 13 12 - 16 22 19 - 14 - 14 - 14 19 15 8 - 15 - 19 - 22

    Номер первого из пары элементов с максимальной суммой: 20
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
Опишите на одном из языков программирования алгоритм поиска трех последовательных эле-ментов, сумма которых максимальна, в числовом массиве из 30 элементов. вывести номер эле-мента в этой последовательности, сумму последовательности.
Ответы (1)
2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30. На Паскале АБС
Ответы (1)
Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "NO". В паскале.
Ответы (1)