Задать вопрос
27 марта, 21:23

Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом работы программы является последовательность чисел заканчивающихся (по гипотезе Сиракуза) единицей.

+3
Ответы (1)
  1. 28 марта, 01:12
    0
    Var

    a, b, n, i: integer;

    begin

    readln (a, b) ;

    for i : = a to b do

    begin

    n : = i;

    write (n) ;

    while n 1 do

    begin

    if (n mod 2) = 0 then

    n : = n div 2

    else

    n : = (3 * n + 1) div 2;

    write (' - > ', n) ;

    end;

    writeln;

    end;

    end.

    чесно передрано с некого сайта и доработано под задачу
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)