Задать вопрос
27 июня, 18:16

4. Сформировать целочисленный массив их 15 произвольных чисел. Подсчитать сумму и произведение элементов с нечетными индексами.

+1
Ответы (1)
  1. 27 июня, 21:52
    0
    Program arr;

    var

    a: array[1 ... 15] of integer;

    count, count_odd, num, sum, mult: integer;

    begin

    count : = 1;

    count_odd : = 1;

    num : = 3;

    sum : = 0;

    mult : = 1;

    while count < = 15 do

    begin

    a[count] : = num;

    count : = count + 1;

    num : = num + 3;

    end;

    while count_odd < = 15 do

    begin

    sum : = sum + a[count_odd];

    mult : = mult * a[count_odd];

    count_odd : = count_odd + 2;

    end;

    writeln ('Массив из 15 элементов: 3, 6, 9, ..., 45') ;

    writeln ('Сумма элементов с нечетными индексами: ', sum) ;

    writeln ('Произведение элементов с нечетными индексами: ', mult) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Сформировать целочисленный массив их 15 произвольных чисел. Подсчитать сумму и произведение элементов с нечетными индексами. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Сформировать целочисленный массив 20 элементов. 1) Подсчитать количество положительных элементов. 2) Подсчитать сумму нечетных элементов.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)