Задать вопрос
30 января, 06:42

Сформировать целочисленный массив 20 элементов.

1) Подсчитать количество положительных элементов.

2) Подсчитать сумму нечетных элементов.

+4
Ответы (1)
  1. 30 января, 06:59
    0
    Var

    a:array[1 ... 20] of integer;

    b, c, i:integer; / / b положительные c сумма нечетных i для цикла

    begin

    b:=0;

    c:=0;

    for i:=1 to 20 do begin

    readln (a[i]) ;

    if a[i]>0 then b:=b+1;

    if a[i] mod 20 then c:=c+a[i];

    end;

    writeln (b) ;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать целочисленный массив 20 элементов. 1) Подсчитать количество положительных элементов. 2) Подсчитать сумму нечетных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)