Задать вопрос
3 января, 00:29

Программирование. Найти слово минимальной длины.

+3
Ответы (1)
  1. 3 января, 00:50
    0
    Uses crt;

    Var s, p:string; i, k, min, max, x, y:integer;

    Begin

    ClrScr; Write ('Input string:') ; Readln (s) ;

    min:=length (s) ;

    For i:=1 to length (s) do

    If not (s[i]=' ') and not (i=length (s)) then p:=p+s[i] else{выделяем слова}

    Begin

    If i=length (s) then p:=p+s[i];

    If length (p) >max then

    Begin

    max:=length (p) ; x:=Pos (p, s) ; {находим самое длинное слово и его позицию}

    End;

    If length (p) Begin

    min:=length (p) ; y:=Pos (p, s) ; {находим самое короткое слово и его позицию}

    End;

    p:=''; inc (k) ;

    End;

    Writeln ('Words:', k) ; {вывод кол-ва слов}

    Writeln ('Long:', x,' Short:', y) ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование. Найти слово минимальной длины. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование циклических алгоритмов. Программирование циклов с заданнымусловием продолжения работы. Задача: Клиент открыл счет в банке в 2017 году, вложив 1000 рублей.
Ответы (1)
Программирование цикл вайл язык С Вопрос №737412 (тип: C) Дано натуральное число N (N
Ответы (1)
1. С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел. (Тема: Программирование ветвлящихся и цепленных алгоритмов) 2. Дано двухзначное число, найти сумму и произведение его чисел.
Ответы (1)
Определение минимальной длины изгороди садового участка. Садовой участок прямоугольной формы имеет площадь S. При каких размерах длины и ширины участка длина изгороди будет наименьшей? Составить геометрическую и математическую модель.
Ответы (1)
9 класс Циклическое программирование 1. Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до 45 2. Найти сумму нечетных чисел от 79 до 205 3. Найти значение функции на отрезке [1; 10] с шагом 0,5
Ответы (1)