Задать вопрос
14 апреля, 08:29

Числа вводятся с клавиатуры, пока не будет введён 0. Вычислите среднее арифметическое этих чисел. Первое же число может оказаться нулём. Выведите в этом случае соответствующее текстовое сообщение.

+3
Ответы (1)
  1. 14 апреля, 09:00
    0
    Program test; var x, i, S, SA:real; begini:=1; read (x) ; S:=x; if x0 then repeat begin read (x) ; S:=S+x; i:=i+1 end; until x0; if S=0 then write ('Первое число ноль') ; if S0 then begin SA:=S/i; writeln (SA) end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Числа вводятся с клавиатуры, пока не будет введён 0. Вычислите среднее арифметическое этих чисел. Первое же число может оказаться нулём. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
С клавиатуры вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Посчитайте количество единиц в этой последовательности, количество двоек, количество троек и так далее (программа должна вывести ровно 9 чисел).
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)