Задать вопрос
17 января, 11:15

Помогите написать программу на Паскале

Дан массив. вставить число К перед и после элементов, которые заканчиваются на ту же цифру, что и К

+2
Ответы (1)
  1. 17 января, 13:04
    0
    Const n=10;

    type mas=array[1 ... 3*n] of integer;

    procedure ins (var a:mas; k, nom:integer) ;

    var i:integer;

    begin

    for i:=3*n downto nom+3 do a[i]:=a[i-2];

    a[nom+1]:=a[nom]; a[nom]:=k; a[nom+2]:=k;

    end;

    var b : mas; k, i, j : integer;

    begin

    Randomize;

    for i:=1 to n do begin

    b[i]:=random (51) ;

    write (b[i]:4) ;

    end;

    writeln;

    write ('K=') ; readln (k) ;

    j:=1;

    for i:=1 to n do

    if (b[j] mod 10 = k mod 10) then

    begin ins (b, k, j) ; j:=j+3 end

    else j:=j+1;

    for i:=1 to 3*n do write (b[i]:4) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на Паскале Дан массив. вставить число К перед и после элементов, которые заканчиваются на ту же цифру, что и К ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)