Задать вопрос
6 апреля, 17:15

В центре системы координат начерчена окружность радиусом R. Известны координаты трех точет на плоскости. Опредедить, сколько из них попали в нарисованный круг. Координаты точек и радиус R вводятся с клавиатуры

+3
Ответы (1)
  1. 6 апреля, 17:44
    0
    Var R, x, y : real; k, i: integer;

    begin

    write ('R=') ; readln (R) ;

    k:=0;

    for i:=1 to 3 do

    begin

    write ('x = ') ; readln (x) ;

    write ('y = ') ; readln (y) ;

    if sqrt (x*x+y*y) <=R then k:=k+1;

    end;

    writeln ('В круг попали ', k,' точек') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В центре системы координат начерчена окружность радиусом R. Известны координаты трех точет на плоскости. Опредедить, сколько из них попали ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
С клавиатуры последовательно вводятся координаты точек. Сколько точек попадут в окружность с центром в начале координат и радиусом R. Конец ввода точек-ввод точки (0; 0)
Ответы (2)
С клавиатуры вводятся пары вещественных чисел - координаты x и y точек на плоскости. Координаты 0,0 служат для окончания ввода. Вывести на экран координаты точки, находящейся на максимальном расстоянии от начала координат.
Ответы (2)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)