Задать вопрос
3 февраля, 02:30

С клавиатуры последовательно вводятся координаты точек. Сколько точек попадут в окружность с центром в начале координат и радиусом R. Конец ввода точек-ввод точки (0; 0)

+4
Ответы (2)
  1. 3 февраля, 03:51
    0
    Program n1;

    var r, k, x, y: real;

    begin

    readln (r) ;

    readln (x, y) ;

    k:=0;

    while (x0) and (y0) do

    begin

    if (x*x+y*y<=r*r) then k:=k+1;

    readln (x, y) ;

    end;

    writeln (k) ;

    end.
  2. 3 февраля, 04:59
    0
    Var r, x, y: real; k:integer;

    begin

    write ('R = ') ;

    readln (r) ;

    write ('x, y: ') ;

    readln (x, y) ;

    k:=0;

    while (x0) and (y0) do

    begin

    if (x*x+y*y<=r*r) then k:=k+1;

    write ('x, y: ') ;

    readln (x, y) ;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    R = 3

    x, y: 2 3

    x, y: 2 1

    x, y: - 2.5 - 2.5

    x, y: - 1 - 1

    x, y: - 2 2

    x, y: 0 0

    k = 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры последовательно вводятся координаты точек. Сколько точек попадут в окружность с центром в начале координат и радиусом R. Конец ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
С клавиатуры вводятся пары вещественных чисел - координаты x и y точек на плоскости. Координаты 0,0 служат для окончания ввода. Вывести на экран координаты точки, находящейся на максимальном расстоянии от начала координат.
Ответы (2)
В центре системы координат начерчена окружность радиусом R. Известны координаты трех точет на плоскости. Опредедить, сколько из них попали в нарисованный круг. Координаты точек и радиус R вводятся с клавиатуры
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)