Задать вопрос
20 сентября, 06:33

Составьте программу, которая запрашивает числитель и знаменатель неправильной дроби и выделяет целую часть (с помощью оператора выбора case)

Например:

Числитель и знаменатель: 17 3

17/3=5 2/3

+2
Ответы (1)
  1. 20 сентября, 07:01
    0
    Программа на языке pascal:

    Var x, y, ostatok:integer;

    Begin

    Writeln ('Введите числитель') ;

    Readln (x) ;

    Writeln ('Введите знаменатель') ;

    Readln (y) ;

    ostatok:=x mod y;

    Writeln ('Дробь после выделения целой части: ', ostatok,'/', y) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая запрашивает числитель и знаменатель неправильной дроби и выделяет целую часть (с помощью оператора выбора ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу выбора дня недели, не используя оператора выбора case a of. Каждый день пронумерован от 1 до 7.
Ответы (1)
помогите написать программу в паскале с помощью оператора выбора (case ... of ... else) : Напишите программу для вычисления степени введённого с клавиатуры числа. Степень в диапазоне 0 ... 9. p.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Напишите программу суммы двух чисел а) с помощью оператора присваивания б) с помощью оператора ввода
Ответы (2)
Аписать на Паскале программу с использованием оператора Repeat ... until, которая запрашивает с клавиатуры набор произвольных целых положительных чисел и ищет их сумму. Признаком окончания последовательности чисел является "0".
Ответы (1)