Задать вопрос
14 декабря, 00:11

помогите написать программу в паскале с помощью оператора выбора (case ... of ... else) :

Напишите программу для вычисления степени введённого с клавиатуры числа. Степень в диапазоне 0 ... 9.

p. s: я начинающий в программировании, поэтому прошу попонятней написать.

+4
Ответы (1)
  1. 14 декабря, 03:36
    0
    var a, b, c:integer;

    begin

    writeln ('введите число и степень') ; {здесь прост программа тебя спрашивает какие числа}

    read (a, b) ; {здесь программа читает их}

    case b of {тут выполняется условие типа если b ... и идут сами степени}

    0: writeln (1) ;

    1: writeln (a) ; {здесь что программа выдаст если ты напишешь такую степень}

    2: writeln (a*a) ;

    3: writeln (a*a*a) ;

    4: writeln (a*a*a*a) ;

    5: writeln (a*a*a*a*a) ;

    6: writeln (a*a*a*a*a*a) ;

    7: writeln (a*a*a*a*a*a*a) ;

    8: writeln (a*a*a*a*a*a*a*a) ;

    9: writeln (a*a*a*a*a*a*a*a*a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «помогите написать программу в паскале с помощью оператора выбора (case ... of ... else) : Напишите программу для вычисления степени ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Написать программу в паскале, которая после введенного с клавиатуры числа (в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово "Копейка". Например, 5 копеек, 41 копейка и тд.
Ответы (1)
Написать программу выбора дня недели, не используя оператора выбора case a of. Каждый день пронумерован от 1 до 7.
Ответы (1)
1. Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. 2. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)