Задать вопрос
23 октября, 09:47

Аписать на Паскале программу с использованием оператора Repeat ... until, которая запрашивает с клавиатуры набор произвольных целых положительных чисел и ищет их сумму. Признаком окончания последовательности чисел является "0".

+1
Ответы (1)
  1. 23 октября, 12:07
    0
    Program z; var a, mplus, i:integer; masiv:array of integer; begin repeat inc (mplus) ; setlength (masiv, mplus) ; read (i) ; a:=a+i; until i=0; writeln (a) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Аписать на Паскале программу с использованием оператора Repeat ... until, которая запрашивает с клавиатуры набор произвольных целых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Где ошибка? Задание: Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры.
Ответы (1)
Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму. число N вводится с клавиатуры.
Ответы (1)
Как сделать задачу в turbo pascal которая запрашивает с клавиатуры 2 произвольных числа X и Y. Если разность X и Y больше 0, то вычисляет и выводит на экран сумму всех целых чисел от Y до X, иначе вычесляет и выводит на экран разность всех целых
Ответы (1)
Составить программу на языке pascal. используя цикл repeat ... until. Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)