Задать вопрос
18 октября, 06:23

Где ошибка?

Задание: Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для созданной программы не менее трёх тестов и проверить на них правильность работы алгоритма.

Я написала так:

uses crt;

var n, i, s, c:integer;

begin

clrscr;

readln (n) ;

s:=0;

for i:=1 to n do

begin

readln (c) ;

s:=s+c;

end;

writeln (s) ;

readkey;

end.

Где здесь допущена ошибка? Помогите!

+5
Ответы (1)
  1. 18 октября, 09:04
    0
    Может задачу недопонял. Но вот что вышло:

    uses crt;

    var n, i, s:integer;

    begin

    clrscr;

    readln (n) ;

    for i:=1 to n do

    begin

    s:=s+i;

    end;

    writeln (s) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Где ошибка? Задание: Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
надо решать через Паскаль. составил две программы и обе со странным ответом. что не то? program qwe; uses crt; var x. s:integer; y:real; begin s:=0; for i: = - 2 to 27 do s:=s+x; y:=s/30 writeln ('srednee arifmeticheskoe=', y) ; readkey; end.
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m') ; readln (c, m) ; s:=c*m; writeln ('s=', s) ; readln; end.
Ответы (1)
Напишите программу на вычитание, деление и умножение (8-9 класс) На примере: program n_1 uses crt var a, b, c: integar; begin writeln ('введите а: ') ; readln (а) ; writeln (введите b: ') ; readln (b) ; c:=a+b writeln ('сумма = ', c) ; readkey; end.
Ответы (1)
Как сделать теперь без массива (паскале) ? var nm:array of integer; j, l:integer; begin nm: = new integer[3] (random (20), random (20), random (20)) ; writeln ('nm[0] = ', nm[0]) ; writeln ('nm[1] = ', nm[1]) ; writeln ('nm[2] = ', nm[2]) ;
Ответы (1)