Задать вопрос
5 августа, 04:32

Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу.

+1
Ответы (1)
  1. 5 августа, 07:04
    0
    var i:word; переменная через которую будут проходить все трехзначные цифры

    s:longint; переменная для хранения суммы

    begin

    s:=0; -обнуляем переменную где будем сохранять сумму

    write ('Числа: ') ;

    for i:=100 to 999 do начинаем перебор всех трехзначных цифр

    if i mod 2 = 0 then проверка на четность, мод - это деление по остатку, т. е в ответ записывается остаток от деления

    if i mod 7 = 0 then begin write (i,' ') ; s:=s+i; end; выводим четное число кратное 7 и в тоже время суммируем его с последующими четными кратных 7 ми, в переменной s

    writeln; пропускаем строку

    writeln ('Сумма всех всех четных трехзначных чисел, которые делятся на 7 = ', s) ; выводим на экран результат

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Каждый из 35 участников олимпиады по программированию владеет Паскалем, Бейсиком или двумя языками сразу. В анкете 25 человек указали владения Паскалем, А 22 - Бейсиком. Сколько участников программируют только на Паскале?
Ответы (2)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)